java.lang.IllegalArgumentException: Array of strings are not implemented yet

FETPAPI should do it for you behind the scene. You have not to deal with that at least in a first/basic usage.
If you really want to for some more advanced usage, you still can but I definitely think this is not the way to start to learn how to use FETPAPI.

That’s an encouraging comment that Fetpapi will do this for us. The only thing I am worried about it that we need to show this urgently and I am kind of stuck thats why started exploring different possibilities.

Indeed, this is drawback of community support. Industrial delivery withtout industrial support is always a risky bet.
I cannot dedicate more time than I do on this bug. And this bug deserves either more time and/or more environment access at a first glance.

Indeed, we are exploring different possibilities mainly because it is not reproducible on my various environments (vs2017 + CSharp, VS2017 + Java8, GCC4.8 + Java8, VS2017 c++, VS2022 c++ without any compiler optimization). Providing a way to reproduce the bug may accelerate the fix but I don’t know how much since it only depends on my free time…

Yes you’re right.

I was using java 11, reverted back to 8 but no luck.

We built the api without any optimisatio. Not sure what’s the default and how it effects. Can you please guide where we can can check and if we need to rebuild.

On this image coming from a build with VS2017, you see the highlighted /O and /Ob flags which are related to optimization.
You would need to remove them or to put them to 0 (as for the debug line). Regenerate the solution from Cmake and rebuild the library.

On different compiler, it might be a different flag but you should be able to see them in CMake as the image hereunder shows you.

The java version does not change a lot.
The C++ optimisation may change more but there is no guarantee at all.

Again, if you can provide a docker image of your client (I’ll use my own etp server) which reproduces the error, it would help.

Used this command for windows

Yeah thats the best way. Actually I am doing this on my windows home edition. Docker desktop is crashing for no reason. Not able to build an image.

If I understand correclty, you actually build fetpapi with visual studio 2019.
If so you can disable C++ optimization by removing the /O flags using CMake-GUI (see previous snapshot)
or you can disable them directly in Visual Studio (Disable Optimization and Inline function Expansion)

You could also decide to override the default CMake flags on line 73 of fetpapi/github-actions.yml at dca231cd396f5662e3b478dfdef2a59284e666de · F2I-Consulting/fetpapi · GitHub adding something like -DCMAKE_CXX_FLAGS_=

Perfect. Thank you very much. We will build again and test.

Is it possible to for you to provide the libraries so that I can quickly see if it makes any change?

I’ll try but I would have to package all my dev environment (fesapi and its dependencies, fetpapi and its dependencies) which is going to take me time.

1 Like

That would be really helpful

We tried to build but it failed due to some issues, maybe due to our local configurations. We will try again but I don’t know we will succeed or not. Please if you get time share your libraries so that we can meet the coming deadline.

Many thanks in advance.

No luck…
On my side, I have a Java version working on CentOS7, a VS2022 pure C++ on Windows (on my main collaborator computer) and a VS2017 C# version on Windows.
My FETPAPI Windows java version is still in dev on windows : it was working on FESAPI 2.5 but I upgraded my dev env to v2.6 and I have to reconfigure this env for this particular version to work.

It is going to take me time and definitely community support is not suitable for that. I am quite busy with my paying customers and it is fair to give them the top priority. They have also urgency with their own deadlines and I am paid to help them achieving that (with FESAPI and FETPAPI).

So, I cannot guarantee any deadline so far as I am sure you would understand.
Community support is good for answering questions and giving directions but not really for realizing things according to deadline.

No problem I understand. I am trying to build it myself.

You can try this version :

This is the quickest I can do. It is based on VS2017.
You may need to install the VS2017 redistributable in the same directory.

It works on my computer.

1 Like

Thank you very much. Let me try.

Still getting the same error.

Can you please suggest a workaround in case we are not able to fix in our environment?

I cannot think of any workaround.
There must be a bug in FETPAPI which only occurs unders some circumstances/environments.

I’ll have to be able to reproduce the bug and debug it.
The way to debug is :

  • either to make it reproducible in C++
  • or attach FETPAPI or FESAPI to the running problematic JAVA application
    and go step by step…

In all cases, it does not look as a short term solution.

You are right. By workaround I meant reading arrays in chunks instead of reading the whole array.